PhpStorm

С недавних пор начал плотно использовать PhpStorm на работе – с появлением в системнике “лишней” памяти она (IDE) стала ну просто космически быстрой, дьявольски умной и невероятно удобной. Одно тяготило меня – не нашёл возможности увидеть вывод отлаживаемого скрипта. Особенно

Добавляем действия в контектное меню KDE

Многие операции вроде “замаунтить флешку”, “скопировать файл” и т.п. ежедневно-рутинные действия я не задумываясь совершаю в консоли (благодаря yakuake она всегда под рукой). Но перед людьми бывает “неудобно” – они видя все эти “магические” манипуляции ещё больше укрепляются в мысли,

node.js on windows

Только недавно я восхищался (да и пока не перестал) node.js и вот совершенно случайно наткнулся на бинарники node.js под винду, а прямо рядом с ними очень интересное альтернативное мнение о node. Написано по-русски, доступным языком. Задумался. Но изучать не перестал.

jabber web status

В поисках прикладной задачи для предметного изучения node.js вспомнил про заброшенный проектик – jabber web status. И за несколько часов переписал на node. По сравнению с предыдущей версией написанной на PHP (XMPPHP) потребление памяти, а главное, нет ГЛАВНОЕ – потребление

Adobe AIR и linux. Часть II.

В начале года мне уже удалось установить Adobe AIR на свой slackware. Но спустя несколько месяцев вышел свежий релиз (2.0) и инструкция стала неактуальной. Я обещал разобраться и выложить обновлённую. Хотя и прошло почти полгода, но лучше поздно, чем никогда,

Subversion и время модификации файлов

Крайне странно что раньше я не замечал по-умолчанию директива use-commit-times ВЫКЛЮЧЕНА!. Включить, понятное дело, можно настройкой в конфиге ~/.subversion/config. Ну или в cli добавив параметр –config-option=config:miscellany:use-commit-times=yes

watir и ruby1.9

В системе обновился ruby до 1.9 и после переустановки нужных gem-ов ВНЕЗАПНО обнаружилось, что watir не грузится. /usr/lib/ruby/gems/1.9.1/gems/user-choices-1.1.6/lib/user-choices/arglist-strategies.rb:152: warning: else without rescue is useless /usr/lib/ruby/gems/1.9.1/gems/user-choices-1.1.6/lib/user-choices.rb:1:in `require’: /usr/lib/ruby/gems/1.9.1/gems/user-choices-1.1.6/lib/user-choices/arglist-strategies.rb:148: syntax error, unexpected ‘:’, expecting keyword_then or ‘,’ or ‘;’ or ‘\n’ (SyntaxError)